aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <matt@matthewlemon.com>2022-06-27 12:17:50 +0100
committerMatthew Lemon <matt@matthewlemon.com>2022-06-27 12:17:50 +0100
commit8fae25cbb3e50e75dc11134f63dad377362e65f6 (patch)
tree7d98b1c1478b173f590a04dc87c8b8dfee9681e2 /pyproject.toml
parentpyproject.toml is currently broken so 1.1.9 created with setuptools (diff)
evolved to pyproject with hatchling and removed setup.py
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/pyproject.toml b/pyproject.toml
index de7f755..34e4e11 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,6 +2,9 @@
requires = ["hatchling"]
build-backend = "hatchling.build"
+[project.scripts]
+datamaps = 'datamaps.main:cli'
+
[project]
name = "datamaps"
version = "1.1.9"
@@ -9,16 +12,13 @@ authors = [
{ name="Matthew Lemon", email="matt@matthewlemon.com" },
]
description='Collect and clean data using Excel spreadsheets.'
-entry_points={'console_scripts': [
- 'datamaps = datamaps.main:cli'
-]},
-install_requires=[
+dependencies = [
'click',
'python-dateutil',
'bcompiler-engine>=1.1.5'
-],
+]
readme = "README.md"
-requires_python = ">=3.7"
+requires-python = ">=3.7"
classifiers=[
"Environment :: Console",
"Intended Audience :: Other Audience",
@@ -29,13 +29,13 @@ classifiers=[
]
[project_urls]
-"Homepage" = 'https://github.com/hammerheadlemon/datamaps'
+"Homepage" = 'https://github.com/yulqen/datamaps'
[tool.poetry]
name = "datamaps"
version = "1.1.7"
-homepage = "https://github.com/hammerheadlemon/datamaps"
-repository = "https://github.com/hammerheadlemon/datamaps"
+homepage = "https://github.com/yulqen/datamaps"
+repository = "https://github.com/yulqen/datamaps"
license = "MIT"
readme = "README.md"
description = "Collect and clean data using Excel spreadsheets."