aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <matt@matthewlemon.com>2022-06-24 18:23:16 +0100
committerMatthew Lemon <matt@matthewlemon.com>2022-06-24 18:23:16 +0100
commit254814feafb5e1e314266d0e7c4b3504fdac6dee (patch)
tree852249c9cde8b75f225556b27f5b0575d146eab9 /pyproject.toml
parentupdated README (diff)
pyproject.toml is currently broken so 1.1.9 created with setuptools
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6625b9b..de7f755 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,11 +4,19 @@ build-backend = "hatchling.build"
[project]
name = "datamaps"
-version = "1.1.8"
+version = "1.1.9"
authors = [
{ name="Matthew Lemon", email="matt@matthewlemon.com" },
]
description='Collect and clean data using Excel spreadsheets.'
+entry_points={'console_scripts': [
+ 'datamaps = datamaps.main:cli'
+]},
+install_requires=[
+ 'click',
+ 'python-dateutil',
+ 'bcompiler-engine>=1.1.5'
+],
readme = "README.md"
requires_python = ">=3.7"
classifiers=[