aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..051725d
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,30 @@
+[build-system]
+requires = ["setuptools", "wheel"]
+
+[tool.poetry]
+name = "datamaps"
+version = "1.0.4"
+homepage = "https://github.com/hammerheadlemon/datamaps"
+repository = "https://github.com/hammerheadlemon/datamaps"
+license = "MIT"
+readme = "README.md"
+description = "Collect and clean data using Excel spreadsheets."
+authors = ["Matthew Lemon <matt@matthewlemon.com>"]
+
+[tool.poetry.dependencies]
+python = "^3.7.0"
+python-dateutil = "^2.8.1"
+click = "^7.1.2"
+#bcompiler-engine = "^1.0.4"
+bcompiler-engine = { path = "C:/Users/lemon/code/python/bcompiler-engine"}
+
+[tool.poetry.dev-dependencies]
+pytest = "^5.4.1"
+pytest-cov = "^2.7.1"
+coverage = "^5.1"
+nox = "^2019.11.9"
+pyinstaller = "^3.6"
+wheel = "^0.34.2"
+
+[tools.black]
+max-length-length=88