aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0cb6687..74d1503 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -136,6 +136,7 @@ target-version = "py312"
select = ["E", "F", "B", "SIM", "I"]
ignore = [
"E501", # line length!
+ "I001", # imports - we are going to let isort do it
"TRY003",
"RUF001",
"COM812",
@@ -161,6 +162,7 @@ extend-unsafe-fixes = [
dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
[tool.ruff.format]
+line-length = 150
quote-style = "double"
indent-style = "space"
skip-magic-trailing-comma = false