aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <y@yulqen.org>2024-09-11 17:24:45 +0100
committerMatthew Lemon <y@yulqen.org>2024-09-11 17:24:45 +0100
commitd36b3fd70b9bd34719fc4d08594563ef73759ee7 (patch)
tree14b1eda72de461280637fbf6341d862212e1c1b0 /pyproject.toml
parenta7afbfd090c3f059eeb0fe1573ca56f4c4cb9867 (diff)
Cleaning up with ruff, typechecking, etc.
I am enabling lots of capability in neovim which is resulting in all this. Don't be scared.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml71
1 files changed, 44 insertions, 27 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5a5455b..b14017f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,29 +2,43 @@
name = "pyblackbird_cc"
version = "0.1.0"
dependencies = [
- "python-slugify==8.0.4", # https://github.com/un33k/python-slugify
- "pillow==10.3.0", # https://github.com/python-pillow/Pillow
- "argon2-cffi==23.1.0", # https://github.com/hynek/argon2_cffi
- "whitenoise==6.6.0", # https://github.com/evansd/whitenoise
- "redis==5.0.4", # https://github.com/redis/redis-py
- "hiredis==2.3.2", # https://github.com/redis/hiredis-py
- "celery==5.4.0", # pyup: < 6.0 # https://github.com/celery/celery
- "django-celery-beat==2.6.0", # https://github.com/celery/django-celery-beat
- "flower==2.0.1", # https://github.com/mher/flower
+ "python-slugify==8.0.4",
+ # https://github.com/un33k/python-slugify
+ "pillow==10.3.0",
+ # https://github.com/python-pillow/Pillow
+ "argon2-cffi==23.1.0",
+ # https://github.com/hynek/argon2_cffi
+ "whitenoise==6.6.0",
+ # https://github.com/evansd/whitenoise
+ "redis==5.0.4",
+ # https://github.com/redis/redis-py
+ "hiredis==2.3.2",
+ # https://github.com/redis/hiredis-py
+ "celery==5.4.0",
+ # pyup: < 6.0 # https://github.com/celery/celery
+ "django-celery-beat==2.6.0",
+ # https://github.com/celery/django-celery-beat
+ "flower==2.0.1",
+ # https://github.com/mher/flower
"botocore~=1.34.93",
-
-# Django
-# ------------------------------------------------------------------------------
+ # Django
+ # ------------------------------------------------------------------------------
"django-storages==1.14.3",
- "Django==5.0.4", # pyup: < 5.0 # https://www.djangoproject.com/
- "django-environ==0.11.2", # https://github.com/joke2k/django-environ
- "django-model-utils==4.5.1", # https://github.com/jazzband/django-model-utils
- "django-allauth[mfa]==0.62.1", # https://github.com/pennersr/django-allauth
- "django-crispy-forms==2.1", # https://github.com/django-crispy-forms/django-crispy-forms
- "crispy-bootstrap5==2024.2", # https://github.com/django-crispy-forms/crispy-bootstrap5
- "django-redis==5.4.0", # https://github.com/jazzband/django-redis
-
-# migrated stuff from pyblackbird
+ "Django==5.0.4",
+ # pyup: < 5.0 # https://www.djangoproject.com/
+ "django-environ==0.11.2",
+ # https://github.com/joke2k/django-environ
+ "django-model-utils==4.5.1",
+ # https://github.com/jazzband/django-model-utils
+ "django-allauth[mfa]==0.62.1",
+ # https://github.com/pennersr/django-allauth
+ "django-crispy-forms==2.1",
+ # https://github.com/django-crispy-forms/django-crispy-forms
+ "crispy-bootstrap5==2024.2",
+ # https://github.com/django-crispy-forms/crispy-bootstrap5
+ "django-redis==5.4.0",
+ # https://github.com/jazzband/django-redis
+ # migrated stuff from pyblackbird
"pdf2image==1.17.0",
"pypdf2==3.0.1",
"python-magic==0.4.27",
@@ -32,18 +46,21 @@ dependencies = [
"boto3==1.34.89",
"sqlparse==0.5.0",
"markdown==3.6.0",
-
- "Werkzeug[watchdog]==3.0.2", # https://github.com/pallets/werkzeug
- "psycopg[c]==3.1.19", # https://github.com/psycopg/psycopg
- "watchfiles==0.21.0", # https://github.com/samuelcolvin/watchfiles
- "stripe==10.10.0"
+ "Werkzeug[watchdog]==3.0.2",
+ # https://github.com/pallets/werkzeug
+ "psycopg[c]==3.1.19",
+ # https://github.com/psycopg/psycopg
+ "watchfiles==0.21.0",
+ # https://github.com/samuelcolvin/watchfiles
+ "stripe==10.10.0",
+ "django-stubs[compatible-mypy]>=5.0.4",
]
[tool.uv] # https://docs.astral.sh/uv/concepts/dependencies/#development-dependencies
dev-dependencies = [
"factory-boy==3.3.0", # https://github.com/FactoryBoy/factory_boy
"django-coverage-plugin==3.1.0", # https://github.com/nedbat/django_coverage_plugin
"pytest-django==4.8.0", # https://github.com/pytest-dev/pytest-django
- "ruff==0.4.4", # https://github.com/astral-sh/ruff
+ "ruff==0.6.4", # https://github.com/astral-sh/ruff
"coverage==7.5.1", # https://github.com/nedbat/coveragepy
"pytest==8.2.0", # https://github.com/pytest-dev/pytest
"pytest-sugar==1.0.0", # https://github.com/Frozenball/pytest-sugar