aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <y@yulqen.org>2024-05-14 13:59:52 +0100
committerMatthew Lemon <y@yulqen.org>2024-05-14 13:59:52 +0100
commitced16ee9dc3bf1790c0345e874dc7861e27c99ca (patch)
tree17cc73c5232b1043d241736c4728904b0fb8f9ed /pyproject.toml
parent46f11648d902b22a177b878e35d6049a7a127ce7 (diff)
Adds crispy forms helper
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml127
1 files changed, 65 insertions, 62 deletions
diff --git a/pyproject.toml b/pyproject.toml
index eba190f..258cdbb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -80,75 +80,78 @@ exclude = [
"staticfiles/*"
]
# Same as Django: https://github.com/cookiecutter/cookiecutter-django/issues/4792.
-line-length = 88
+line-length = 98
indent-width = 4
target-version = "py312"
[tool.ruff.lint]
select = [
- "F",
- "E",
- "W",
- "C90",
- "I",
- "N",
- "UP",
- "YTT",
- # "ANN", # flake8-annotations: we should support this in the future but 100+ errors atm
- "ASYNC",
- "S",
- "BLE",
- "FBT",
- "B",
- "A",
- "COM",
- "C4",
- "DTZ",
- "T10",
- "DJ",
- "EM",
- "EXE",
- "FA",
- 'ISC',
- "ICN",
- "G",
- 'INP',
- 'PIE',
- "T20",
- 'PYI',
- 'PT',
- "Q",
- "RSE",
- "RET",
- "SLF",
- "SLOT",
- "SIM",
- "TID",
- "TCH",
- "INT",
- # "ARG", # Unused function argument
- "PTH",
- "ERA",
- "PD",
- "PGH",
- "PL",
- "TRY",
- "FLY",
- # "NPY",
- # "AIR",
- "PERF",
- # "FURB",
- # "LOG",
- "RUF"
+ "F",
+ "E",
+ "W",
+ "C90",
+ "I",
+ "N",
+ "UP",
+ "YTT",
+ # "ANN", # flake8-annotations: we should support this in the future but 100+ errors atm
+ "ASYNC",
+ "S",
+ "BLE",
+ "FBT",
+ "B",
+ "A",
+ "COM",
+ "C4",
+ "DTZ",
+ "T10",
+ "DJ",
+ "EM",
+ "EXE",
+ "FA",
+ 'ISC',
+ "ICN",
+ "G",
+ 'INP',
+ 'PIE',
+ "T20",
+ 'PYI',
+ 'PT',
+ "Q",
+ "RSE",
+ "RET",
+ "SLF",
+ "SLOT",
+ "SIM",
+ "TID",
+ "TCH",
+ "INT",
+ # "ARG", # Unused function argument
+ "PTH",
+ "ERA",
+ "PD",
+ "PGH",
+ "PL",
+ "TRY",
+ "FLY",
+ # "NPY",
+ # "AIR",
+ "PERF",
+ # "FURB",
+ # "LOG",
+ "RUF"
]
ignore = [
- "S101", # Use of assert detected https://docs.astral.sh/ruff/rules/assert/
- "RUF012", # Mutable class attributes should be annotated with `typing.ClassVar`
- "SIM102", # sometimes it's better to nest
- "UP038" # Checks for uses of isinstance/issubclass that take a tuple
- # of types for comparison.
- # Deactivated because it can make the code slow:
- # https://github.com/astral-sh/ruff/issues/7871
+ "TRY003",
+ "RUF001",
+ "EM101",
+ "S101", # Use of assert detected https://docs.astral.sh/ruff/rules/assert/
+ "RUF012", # Mutable class attributes should be annotated with `typing.ClassVar`
+ "SIM102", # sometimes it's better to nest
+ "UP038" # Checks for uses of isinstance/issubclass that take a tuple
+ # of types for comparison.
+ # Deactivated because it can make the code slow:
+ # https://github.com/astral-sh/ruff/issues/7871
]
# Allow fix for all enabled rules (when `--fix`) is provided.
fixable = ["ALL"]