aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <y@yulqen.org>2025-01-05 19:33:36 +0000
committerMatthew Lemon <y@yulqen.org>2025-01-05 19:33:36 +0000
commit6272ce16883d9337c46af0b790170432b22881ca (patch)
treeace5a43a30caad994fe764a7eeaa7b0349643bc6 /pyproject.toml
parent126a5fb1841aaf95b38cc8d7e5c79561023623f1 (diff)
first attempt - broken Docker implentation
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8ad37ef..0cb6687 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,4 +1,5 @@
[project]
+requires-python = ">=3.11"
name = "alphabetlearning"
version = "0.1.0"
dependencies = [
@@ -38,15 +39,13 @@ dependencies = [
"sqlparse==0.5.0",
"markdown==3.6.0",
"Werkzeug[watchdog]==3.0.2",
- # https://github.com/pallets/werkzeug
- "psycopg[c]==3.1.19",
# https://github.com/psycopg/psycopg
"watchfiles==0.21.0",
# https://github.com/samuelcolvin/watchfiles
"stripe==11.1.0",
"django-stubs[compatible-mypy]>=5.0.4",
# "django-ratelimit==4.1.0",
- "django-recaptcha==4.0.0"
+ "django-recaptcha==4.0.0",
]
[tool.uv] # https://docs.astral.sh/uv/concepts/dependencies/#development-dependencies
dev-dependencies = [