summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <y@yulqen.org>2024-04-23 11:16:38 +0100
committerMatthew Lemon <y@yulqen.org>2024-04-23 11:16:38 +0100
commit0f951dcf029d4af284467543a3afdf5bf6581a20 (patch)
treea48384210cdc168e3bd3ccff6d6d516eeed9e748 /pyproject.toml
parent8b084e9fe7a5f3a04c32daf9a24f7f2cf67300f9 (diff)
switched to Django
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..5743b1a
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,64 @@
+# Some assistance and tips from:://www.tweag.io/blog/2023-04-04-python-monorepo-1/
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.ruff]
+line-length = 120
+
+[tool.djlint]
+profile="django"
+ignore = "H023,H025,H030,H031"
+
+[tool.pyright]
+reportMissingTypeArgument = true # Report generic classes used without type arguments
+strictMissingInference = true # Use union types when inferring types of list elements, instead of Any
+
+[tool.black]
+line-length = 120
+target-version = ['py310']
+
+[tool.isort]
+profile = "black"
+combine_as_imports = true
+include_trailing_comma = true
+line_length = 120
+
+[tool.poetry]
+name = "ded"
+version = "0.1.0"
+description = "Open source regulatory data management and workflow application."
+authors = ["Matthew Lemon <y@yulqen.org>"]
+license = "AGPL v3"
+readme = "README.md"
+
+[tool.poetry.dependencies]
+python = "^3.11"
+django-crispy-forms = "~2.0"
+Django = "~5.0.4"
+faker = "^18.4.0"
+django-htmx = "^1.17.3"
+
+[tool.poetry.group.docs.dependencies]
+sphinx = "~6.1.3"
+myst-parser = "~1.0.0"
+
+[tool.poetry.group.dev.dependencies]
+black = "~23.3.0"
+pre-commit = "~3.2.2"
+django-debug-toolbar = "~3.7"
+flake8 = "~6.0.0"
+pdbpp = "~0.10.3"
+pyright = "~1.1.239"
+mypy = "~1.1.1"
+mypy-extensions = "~1.0.0"
+litecli = "~1.9.0"
+djlint = "~1.23.3"
+isort = "~5.12.0"
+ipython = "~8.12.0"
+jedi = "^0.18.2"
+
+[tool.poetry.group.test.dependencies]
+pytest = "~7.2.2"
+pytest-django = "^4.5.2"