diff options
author | MR Lemon <matt@matthewlemon> | 2020-05-17 16:18:29 +0100 |
---|---|---|
committer | MR Lemon <matt@matthewlemon> | 2020-05-17 16:18:29 +0100 |
commit | 28e844dd1ba1f7c7052bc872b632a5c5d943b295 (patch) | |
tree | db0e3fe48d68322404ecc5a2caf5979a7f1efad2 /dm.spec | |
parent | 2a563abd6b652532f13a97de23392cfe3fc6c6ce (diff) |
added deps and instructions for building with pyinstaller on windows 10
Diffstat (limited to '')
-rw-r--r-- | dm.spec | 33 |
1 files changed, 33 insertions, 0 deletions
@@ -0,0 +1,33 @@ +# -*- mode: python ; coding: utf-8 -*- + +block_cipher = None + + +a = Analysis(['cli.py'], + pathex=['C:\\Users\\lemon\\code\\python\\datamaps'], + binaries=[], + datas=[], + hiddenimports=[], + hookspath=[], + runtime_hooks=[], + excludes=[], + win_no_prefer_redirects=False, + win_private_assemblies=False, + cipher=block_cipher, + noarchive=False) +pyz = PYZ(a.pure, a.zipped_data, + cipher=block_cipher) +exe = EXE(pyz, + a.scripts, + a.binaries, + a.zipfiles, + a.datas, + [], + name='dm', + debug=False, + bootloader_ignore_signals=False, + strip=False, + upx=True, + upx_exclude=[], + runtime_tmpdir=None, + console=True ) |