aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml147
1 files changed, 72 insertions, 75 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 23ac971..c35374b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,73 @@
+[project]
+name = "pyblackbird_cc"
+version = "0.1.0"
+dependencies = [
+ "python-slugify==8.0.4",
+ # https://github.com/un33k/python-slugify
+ "pillow==10.3.0",
+ # https://github.com/python-pillow/Pillow
+ "argon2-cffi==23.1.0",
+ # https://github.com/hynek/argon2_cffi
+ "whitenoise==6.6.0",
+ # https://github.com/evansd/whitenoise
+ "redis==5.0.4",
+ # https://github.com/redis/redis-py
+ "hiredis==2.3.2",
+ # https://github.com/redis/hiredis-py
+ "celery==5.4.0",
+ # pyup: < 6.0 # https://github.com/celery/celery
+ "django-celery-beat==2.6.0",
+ # https://github.com/celery/django-celery-beat
+ "flower==2.0.1",
+ # https://github.com/mher/flower
+ "botocore~=1.34.93",
+ # Django
+ # ------------------------------------------------------------------------------
+ "django-storages==1.14.3",
+ "gunicorn==22.0.0",
+ "Django==5.0.4",
+ # pyup: < 5.0 # https://www.djangoproject.com/
+ "django-environ==0.11.2",
+ # https://github.com/joke2k/django-environ
+ "django-model-utils==4.5.1",
+ # https://github.com/jazzband/django-model-utils
+ "django-allauth[mfa]==0.62.1",
+ # https://github.com/pennersr/django-allauth
+ "django-crispy-forms==2.1",
+ # https://github.com/django-crispy-forms/django-crispy-forms
+ "crispy-bootstrap5==2024.2",
+ # https://github.com/django-crispy-forms/crispy-bootstrap5
+ "django-redis==5.4.0",
+ # https://github.com/jazzband/django-redis
+ # migrated stuff from pyblackbird
+ "pdf2image==1.17.0",
+ "pypdf2==3.0.1",
+ "python-magic==0.4.27",
+ "python-dotenv==1.0.1",
+ "boto3==1.34.89",
+ "sqlparse==0.5.0",
+ "markdown==3.6.0",
+ "Werkzeug[watchdog]==3.0.2",
+ # https://github.com/pallets/werkzeug
+ "psycopg[c]==3.1.19",
+ # https://github.com/psycopg/psycopg
+ "watchfiles==0.21.0",
+ # https://github.com/samuelcolvin/watchfiles
+ "stripe==10.10.0",
+ "django-stubs[compatible-mypy]>=5.0.4",
+]
+[tool.uv] # https://docs.astral.sh/uv/concepts/dependencies/#development-dependencies
+dev-dependencies = [
+ "factory-boy==3.3.0", # https://github.com/FactoryBoy/factory_boy
+ "django-coverage-plugin==3.1.0", # https://github.com/nedbat/django_coverage_plugin
+ "pytest-django==4.8.0", # https://github.com/pytest-dev/pytest-django
+ "ruff==0.6.4", # https://github.com/astral-sh/ruff
+ "coverage==7.5.1", # https://github.com/nedbat/coveragepy
+ "pytest==8.2.0", # https://github.com/pytest-dev/pytest
+ "pytest-sugar==1.0.0", # https://github.com/Frozenball/pytest-sugar
+ "pdbpp==0.10.3"
+]
+
# ==== pytest ====
[tool.pytest.ini_options]
minversion = "6.0"
@@ -35,25 +105,6 @@ ignore_errors = true
[tool.django-stubs]
django_settings_module = "config.settings.local"
-# ==== djLint ====
-[tool.djlint]
-blank_line_after_tag = "load,extends"
-close_void_tags = true
-format_css = true
-format_js = true
-# TODO: remove T002 when fixed https://github.com/djlint/djLint/issues/687
-ignore = "H006,H030,H031,T002,H021"
-include = "H017,H035"
-indent = 2
-max_line_length = 119
-profile = "django"
-
-[tool.djlint.css]
-indent_size = 2
-
-[tool.djlint.js]
-indent_size = 2
-
[tool.ruff]
# Exclude a variety of commonly ignored directories.
exclude = [
@@ -90,63 +141,9 @@ indent-width = 4
target-version = "py312"
[tool.ruff.lint]
-select = [
- "F",
- "E",
- "W",
- "C90",
- "I",
- "N",
- "UP",
- "YTT",
- # "ANN", # flake8-annotations: we should support this in the future but 100+ errors atm
- "ASYNC",
- "S",
- "BLE",
- "FBT",
- "B",
- "A",
- "COM",
- "C4",
- "DTZ",
- "T10",
- "DJ",
- "EM",
- "EXE",
- "FA",
- 'ISC',
- "ICN",
- "G",
- 'INP',
- 'PIE',
- "T20",
- 'PYI',
- 'PT',
- "Q",
- "RSE",
- "RET",
- "SLF",
- "SLOT",
- "SIM",
- "TID",
- "TCH",
- "INT",
- # "ARG", # Unused function argument
- "PTH",
- "ERA",
- "PD",
- "PGH",
- "PL",
- "TRY",
- "FLY",
- # "NPY",
- # "AIR",
- "PERF",
- # "FURB",
- # "LOG",
- "RUF"
-]
+select = ["E", "F", "B", "SIM", "I"]
ignore = [
+ "E501", # line length!
"TRY003",
"RUF001",
"COM812",