aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml14
1 files changed, 2 insertions, 12 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d09d98b..c5f7812 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -10,22 +10,12 @@ dependencies = [
# https://github.com/hynek/argon2_cffi
"whitenoise==6.6.0",
# https://github.com/evansd/whitenoise
- "redis==5.0.4",
- # https://github.com/redis/redis-py
- "hiredis==2.3.2",
- # https://github.com/redis/hiredis-py
- "celery==5.4.0",
- # pyup: < 6.0 # https://github.com/celery/celery
- "django-celery-beat==2.6.0",
- # https://github.com/celery/django-celery-beat
- "flower==2.0.1",
- # https://github.com/mher/flower
"botocore~=1.34.93",
# Django
# ------------------------------------------------------------------------------
"django-storages==1.14.3",
"gunicorn==22.0.0",
- "Django==5.0.4",
+ "Django==5.1.4",
# pyup: < 5.0 # https://www.djangoproject.com/
"django-environ==0.11.2",
# https://github.com/joke2k/django-environ
@@ -55,7 +45,7 @@ dependencies = [
# https://github.com/samuelcolvin/watchfiles
"stripe==11.1.0",
"django-stubs[compatible-mypy]>=5.0.4",
- "django-ratelimit==4.1.0",
+ # "django-ratelimit==4.1.0",
"django-recaptcha==4.0.0"
]
[tool.uv] # https://docs.astral.sh/uv/concepts/dependencies/#development-dependencies