aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <y@yulqen.org>2024-09-11 16:25:09 +0100
committerMatthew Lemon <y@yulqen.org>2024-09-11 16:25:09 +0100
commita7afbfd090c3f059eeb0fe1573ca56f4c4cb9867 (patch)
tree280ed18c3e4121c95515d92e90d0fee715116fdd /pyproject.toml
parentb38e4abf1712cc69db6a164425a99e3cad6d138e (diff)
Some formatting changes and calming down ruff slightly
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml58
1 files changed, 2 insertions, 56 deletions
diff --git a/pyproject.toml b/pyproject.toml
index bd77064..5a5455b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -123,63 +123,9 @@ indent-width = 4
target-version = "py312"
[tool.ruff.lint]
-select = [
- "F",
- "E",
- "W",
- "C90",
- "I",
- "N",
- "UP",
- "YTT",
- # "ANN", # flake8-annotations: we should support this in the future but 100+ errors atm
- "ASYNC",
- "S",
- "BLE",
- "FBT",
- "B",
- "A",
- "COM",
- "C4",
- "DTZ",
- "T10",
- "DJ",
- "EM",
- "EXE",
- "FA",
- 'ISC',
- "ICN",
- "G",
- 'INP',
- 'PIE',
- "T20",
- 'PYI',
- 'PT',
- "Q",
- "RSE",
- "RET",
- "SLF",
- "SLOT",
- "SIM",
- "TID",
- "TCH",
- "INT",
- # "ARG", # Unused function argument
- "PTH",
- "ERA",
- "PD",
- "PGH",
- "PL",
- "TRY",
- "FLY",
- # "NPY",
- # "AIR",
- "PERF",
- # "FURB",
- # "LOG",
- "RUF"
-]
+select = ["E", "F", "B", "SIM", "I"]
ignore = [
+ "E501", # line length!
"TRY003",
"RUF001",
"COM812",