aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthew Lemon <y@yulqen.org>2024-09-08 13:59:10 +0100
committerMatthew Lemon <y@yulqen.org>2024-09-08 13:59:10 +0100
commitdb531eaa027d2abcfcceabfef4b8aa9dc5ca1e5d (patch)
tree47dc0044d1a50c8ffbe689ab9f09ed3bda296ae8 /pyproject.toml
parent50c7d5b46a9e25390ab4c4ff5dcb944a12df2bef (diff)
wip: implementing checkout
- also some formatting changes
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index cb27ff3..23ac971 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -85,7 +85,7 @@ exclude = [
"staticfiles/*"
]
# Same as Django: https://github.com/cookiecutter/cookiecutter-django/issues/4792.
-line-length = 140
+line-length = 100
indent-width = 4
target-version = "py312"
@@ -149,6 +149,8 @@ select = [
ignore = [
"TRY003",
"RUF001",
+ "COM812",
+ "ISC001",
"EM101",
"S101", # Use of assert detected https://docs.astral.sh/ruff/rules/assert/
"RUF012", # Mutable class attributes should be annotated with `typing.ClassVar`